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Power Query and Power Pivot 
If you work with data that has been exported from another system such as a general ledger, 

accounting, ERP, CRM, Salesforce etc. then you probably spend a lot of time transforming and re-

shaping your data to create additional reports, Pivot tables or charts. 

This can be boring, repetitive and time consuming. Consider using the Power Query and Power Pivot 

Add-ins that are now available for Excel. The methods of working are rather different to what we are 

used to and involve our importing data into Excel’s data model and then manipulating it rather than 

opening the file where the data is stored. 

Power Query is included in Excel 2016 and is found on the Data tab in the Get & Transform group. 

The examples in this document use the command New Query from the Get & Transform group. You 

may find that you have a slightly different version and you need to use the Get Data control. 

Excel 2013 and Excel 2010 do not include Power Query but you can download and install the Power 

Query Add-in. There is a separate Power Query tab available when you install the Add-in. 

Power Pivot is included in most commercial editions of Excel 2016 but you need to turn it on before 

you can use it. Some of the commercial editions of Excel 2013 include Power Pivot. You can 

download the Power Pivot Add-in for Excel 2010. 

Turning on Power Pivot in Excel 2016 

1. Click the File tab and then Options (down the end) 

2. Click Add-ins on the left 

3. Down the bottom, click COM Add-ins from the Manage list 

4. Click the Go button 

5. Click Microsoft Power Pivot for Excel and then OK 

 

If you wish to work through the examples included in this document then you can download the 

sample files from the following website: 

www.cleesy.com 

Go down the page until you find the section headed Excel Course Files. 

  

http://www.cleesy.com/
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Appending worksheet data using Power Query 
Appending is where you are combining data from different worksheets into one large, summary 

worksheet. You can combine data from worksheets in the same workbook or from different files.  

Once the Append Query has been created all you have to do is refresh your query and then your 

summary data updates to show the current state of each worksheet. This is so much easier than 

having to open each file on a regular basis and copy and paste the current data onto the summary 

sheet. 

The method we are going to use does not involve opening the files to create the summary sheet. 

Instead we shall create a link to the files to be combined and store their data in the data model. 

Then we create the Append query and finally, deliver the appended data onto an Excel worksheet. 

 

You will need the following files to follow the demonstration: append-north-south and append-east-

west. Download the files and save them to a convenient location. Open one of the files to examine 

the contained data and you will see that they contain similar worksheets but with a different data 

population. Close the file. 

Getting the data into the data model 
Click the Data tab and then click New Query 

in the Get & Transform group. Click From File 

and then From Workbook. 
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Choose the append-east-west file from the list and click the Import button. Check Select Multiple 

items in the Navigator and then click either the worksheets or the tables for East and West. Click the 

Load button. Repeat this process for the append-south-north file. 

Where is your data? It’s not in the 

worksheet; it’s in the data model. You 

should see that the Workbook Queries pane 

is visible so that you can see the queries that 

you have made. 

If you can’t see it, click the Show Queries 

control in the Get & Transform group. 
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Appending the data 
Click New Query again and then Combine Queries, Append. 

 

Click the Three or more tables option button and then select your tables from the Available tables 

list and add them to the Tables to append list. You can use the CTRL or SHIFT keys to make a 

multiple selection before clicking the Add button. Click OK. 
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Your appended data will be displayed in the Power Query Editor so that you could continue working 

on it but all we needed was the append so you click the Close & Load control and all your data will 

appear in Excel. 

 

Here’s the list of Workbook Queries that we 

have created and we do not have to repeat 

them. Next time you need your appended data 

you just refresh the queries. 

No more copy and paste! 

When your data appears in the Excel worksheet 

it is contained in an Excel table, which is a 

perfect data source for a Pivot Table or 

summary formulas. If you don’t like the table 

formatting that Excel applies then choose a 

different colour scheme from the Tables Styles 

gallery, which is found on the Tables Tools, 

Design tab in Excel 

 

 

If you don’t want any fancy 

formatting at all then click 

on the very first table 

design in the Light category. 
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Refreshing the data 
We had better check that everything is working. Open one of your source data files, make a few 

changes and then save the file.  

Click Refresh on the Table Tools tab 

and then Refresh All to update your 

queries. 

 

 

 

 

 

 

 

We added a few new rows to the South 

table and you see that the updated data has 

flowed through to the append query. 

If you have a Pivot Table using this as its 

source data refresh the Query first and then 

refresh the Pivot Table. 
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Editing an Append query 
You need the append-monthly file to follow the demonstration. Download the file and save to a 

convenient location. Open the files to examine the contained data and you will see that you have 

twelve monthly worksheets, we need to regularly create a summary sheet from the sheets. 

Once the Append Query has been created all we will have to do is refresh the query and have our 

summary data updated to show the current state of each worksheet. This is so much easier than 

having to open each file on a regular basis and copy and paste the current data onto the summary 

sheet. Notice that some of the headings are in a different order. Close the file. 

 

As before, we need to populate the data model. Click the Data tab and then click New Query in the 

Get & Transform group. Click From File and then From Workbook. 

In the Navigator, you will see 24 items, 12 tables 

and 12 worksheets. Either will do. 

So glad we know how to do block selection. Click 

Select multiple items then check the April box, 

hold down the SHIFT key and check the 

September box. 
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This is the boring bit. Watching whilst the data is loaded 

and the queries are created. But you only have to do it 

once. 

You will see that the empty tables have one row loaded, 

that’s because a table must have a header row and at 

least one row for the first element of data. 

 

 

 

 

 

 

 

 

 

 

At last. Click Combine Queries and Append as before. 

 

Now we shall try the append query. Click Three or more tables and choose the tables from the 

Available tables list. Click the first table, hold down the SHIFT key and then click the last one. Click 

Add and then OK. 
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The tables are appended in the alpha order. Notice that the mismatch of column order does not 

matter, so long as the field name is the same they will append successfully. Note the null values for 

those tables where we had empty rows. 

When we click Close & Load to return the data to the Excel worksheet we notice that the date 

format is wrong and we have blank rows for the nulls. The nulls values in the date column have 

prevented the dates from being read successfully. They are the right values—date serial values but 

we need to format them as dates to make them readable. You easily sort this out in Excel but the 

whole point of using Power Query is that it’s a script for your data routines, get it right once and 

then you’ll never have to repeat any work in the future. 

 

We’ll edit our query, remove the blank rows, format the dates and sort the data into calendar order. 

Click Launch Power 

Query Editor to return 

to the editor. 
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To remove the Null values, click the 

filter drop down list at top of any 

column and clear the check box for 

(null) 

Now that action is added to your M 

script. Everything you do in Power 

Query is recorded in the M language. 

You can see the actions in your script 

in the Applied Steps list on the left. 

 

 

To format the date column to dates, click the column and then set the Data Type to Date then 

choose a suitable date format picture from the list. 

Right-click the date column and sort the data 

in Ascending order.  

Click Close & Load and we’re back in Excel 

with our perfectly formed data. 
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Once you get the Append query working perfectly you don’t need to go back into the Query Editor 

again. You just click Refresh, then Refresh All on the Query tab.  

We are particularly pleased that we don’t have to do the twelve-

month summary manually any more. It was a monthly task and 

although it was primarily just the new data for that month that 

needed including in the summary we found that, in practice, people 

were always going back and changing their historic data so each 

month had to done again. But now clicking Refresh combines the 

current state of the data. And that’s a copy and paste we shall not 

miss. 
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Merging worksheet data using Power Query 
Merging is where you are joining different tables together. For example, you have a data table of 

sales records and you are using VLOOKUP to bring in information about the product based on the 

name of the product sold.  Your product class information is located in another table on a different 

sheet or workbook. 

VLOOKUP formulas are great fun, but they usually entail adding thousands of formulas to your 

workbook, thus increasing the file size and calculation time. Power Query uses SQL joins; this is 

much easier to do and far more efficient. 

Again, the method we are going to use does not involve opening the files to create the merged data. 

Instead we shall create a link to the files to be merged and store their data in the data model. Then 

we create the Merge query and finally, deliver the merged data onto an Excel worksheet. 

 

 

You will need the following files to follow the demonstration: 

transactions and class. Download the files and save them to a 

convenient location. Open the files to examine the contained 

data and you will see that transactions is a table of sales records 

and class is a lookup table cross referencing the product name 

with its class. We need to add a Class column to the transactions 

worksheet. Close the files. 

 

Getting the data into the data model 
Click the Data tab and then click New Query in the 

Get & Transform group. Click From File and then 

From Workbook. 
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Select the class file from the list and click Import. In the Navigator, click the productclass table and 

then click the drop-down arrow next to the Load button at the bottom of the Navigator and click 

Load To. 

Click Only Create 

Connection under Select 

how you want to view this 

data in your workbook. 

Then click the Add this data 

to the Data Model 

checkbox. Click the Load 

button.  

Repeat the process on the 

transactions file and load 

the actuals table. 
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The data model is now populated. 

 

 

 

 

 

 

 

 

 

Merging the data 
Click New Query again and then Combine Queries, Merge. 
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We now need to select the matching columns that will create the merge. Click actuals from the 

drop-down list of tables and then click Product to nominate it as the matching column. Then select 

productclass from the other list and again click Product. The match is made and you click the OK 

button to merge the tables. 

 

Your merged data will be displayed in the 

Power Query Editor where there’s a new 

column at the end. We’re nearly finished, 

click the expand control (double-headed 

arrow on the right) 

Click the Expand option and the Class 

checkbox. Clear the Use original column 

name as prefix checkbox. Click OK and you 

will see your Class column displayed as you 

want it. 
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The merge is completed so you click the 

Close & Load control and all your data will 

appear in an Excel table. 

 

 

Refreshing the data 
We had better check that everything is working. Open the class file and change the Commercial 

entry to Virtual, then save the file. Click Refresh to update your data. 

 

If you have a Pivot Table using this table as source data refresh the Query first and then refresh the 

Pivot Table. I’m missing my VLOOKUP’s already. 
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Unpivoting worksheet data using Power Query 
When you need worksheet data as a source for your Pivot Table is it often in the usual matrix form 

that people prefer to use. Here is the worksheet with my Product and Country estimates. 

 

Pivot Tables can't read data in the matrix form, they need to be fed 

data in the tabular form. Human beings don't produce worksheet 

data in this form, we must unpivot our original data. 

You need the estimates file for this demonstration. 

Click the Data tab and then click New Query in the Get & Transform 

group. Click From File and then From Workbook. In the Navigator 

choose the LE 2016 sheet and load to the data model. 

 

Wait for the query to be created and then click Launch Power Query Editor.  
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We need to remove the total column from the end and also the total row from the bottom. Then we 

turn the columns the other way round. 

 

Click the Total column and then click Remove Columns on the Home tab. 

 

Then click the Remove Rows control, choose Remove Bottom Rows from the menu and enter the 

value of 1 to remove the bottom row from the table. 
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To turn the table around, select the first column and then click the Unpivot Columns control on the 

Transform tab. Then choose Unpivot Other Columns. 

 

The data is now transformed into the tabular form which we need for our Pivot Tables. All we need 

to do is rename the column headings. 

Just right-click each heading in 

turn and choose Rename from the 

shortcut menu. 
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Once again, we can see that all our actions have 

created a script which is visible in the Applied Steps 

list.  

This means that we can update the values on our 

original estimates worksheet and then Refresh to have 

those changes expressed in our Pivot Table report. 

If you ever wish to see the M language instructions in 

Power Query then click the Formula Bar checkbox in 

the Layout group on the View tab.  

As you click the step you can see the M instruction. 

Don't click the cross on the left hand right, that is 

Undo. 

  



22 
 

Beyond Pivot Tables: Power Pivot 
You can use Power Pivot to create Pivot Tables directly from different data sources, link them 

together through table relationships and then calculate on the results using the DAX (Data Analysis 

Expressions) formula language. 

Turn on Power Pivot 
Power Pivot is available in most commercial versions of Excel 2016 but you have to turn it on first. 

Click File, Options, Add-ins. Look down the bottom for Manage and then choose COM Add-ins from 

the drop down list. Click the Go button. Select Microsoft Power Pivot for Excel from the list. 

 

This should give you a Power Pivot tab on the ribbon. 

Creating a Report 
You will need the transactions file to follow the demonstration. Download the file and save it to a 

convenient location. Open the file and examine the contained data and you will see that there are 

two worksheets, Actual and Budget. Historic sales data for a few years and sales estimates for 2016 

analysed by Country and Product. 

In some of the illustrations here, the original table name Data is used instead of Actual. 

 

 

We need to compare our actual performance against our estimates. We can’t merge or append our 

tables, as they are completely different. We need to relate them so that we can do our reports.  

Close the file and we will bring the data into the data model then relate our tables. Finally, we 

produce a Pivot Table report from the data in the data model. 
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Getting the data into the Data model 
Let’s go in the front door to Power Pivot. Click Manage on the Power Pivot tab and wait while 

everything loads.  

 

In the Power Pivot window, click From Other Sources in the Get External Data group. Scroll all the 

way down to the end and click Excel File. Click Next. Click the Browse button, locate the 

transactions file and click the Open button. Don’t forget to check the Use first row as column 

headers checkbox. Click Next. 

 

 

 

We are now in the Table Import Wizard. Click the Budget and Actual checkboxes; click Finish then 

Close when your data is imported. We are now in the data model and we can see the table data. 
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This is populating the data model using the Power Pivot interface. We could just have well started as 

we did in the previous examples Click the Data tab and then click New Query in the Get & Transform 

group. Click From File and then From Workbook. 

Relating the tables 
We are in the Data View and we need to click Diagram View 

to get into the view where we can relate our tables.  

Drag the Country field from Budgets over to the Country field 

from Data to create the relationship. But there’s a problem! 

 

 

We can only produce One-to-Many relationships, where one table has a unique list of values and the 

other contains duplicate values. But both our tables contain duplicate values. We need a Many-to-

Many relationship. No problem, we just use the old database trick of creating bridge tables. We 

need two tables, one containing a unique list of Country names and the other a unique list of 

Product names. 

We can either do this in Excel by copying the sheets and using the Remove Duplicates control on the 

Data tab removing duplicates for both countries and products. Or we could do it through Power 

Query by duplicating the Budgets table twice and then removing duplicates. 
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Here's the Excel method, I have two tables with 

unique values for Country and Product. 

On the Tables worksheet, click any cell in the 

Country table and then click Add to Data Model on 

the Power Pivot tab. Repeat this for the Product 

table. 

Now we can relate the Budget table to the Actual 

table by linking them through the Country and 

Products tables. 

 

 

 

 

 

 

 

Click Diagram View again in the Power Pivot window and drag the Country field from Budgets to the 

Country field of Country. Then drag the Country field from Actual to the Country field of Country. 

Repeat the process for the Product fields. We have created Bridge Tables and linked our original 

tables together through a series of One-to-Many relationships. 

 

There is no real need to move the tables into this harmonious arrangement but some people find it 

pleasing. Now we are ready to create our Pivot Table report comparing our actuals against budget. 
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Creating the Pivot Table report 
Now everything is linked together the reports are easy to do. Click either PivotTable in the Power 

Pivot window or switch back to Excel and click Insert, Pivot Table and Use this workbook’s Data 

Model. 

In the PivotTable fields list you will see the 

different tables and their contained fields.  

Whenever you need a list of Countries or 

Products take these fields from the Country or 

Product tables--the one tables. Don’t take them 

from either Budgets or Data, these are the 

many tables and you will get some strange 

looking results where every number is the 

same. Only take the data to be aggregated from 

the many tables. 

In the Pivot Table below, the countries are the 

Country field from the Country table. Sum of 

Budget is from the Budget table and Sum of 

Revenue from the Actual table. 

 

 

The results look a bit odd; our Revenue is way over Budget. That’s because the Budget numbers are 

for one year, 2016 and the Revenue is historic for 2014 to 2016. We could put a Timeline filter on 

Revenue to show only the year 2016 but then we also want to calculate the difference between 

Budget and Revenue and for that we must use DAX. 

There are two types of DAX formula. Firstly, Calculated Columns, which are entered in the data 

model and which generate new columns of data and secondly, Measures. 

Measures are entered in the Pivot Table. They do not generate new columns of data but rather 

deliver filtered data that is used in the Pivot Table report. We shall have a Calculated Column to help 

us make the filter for 2016 Revenue then two Measures, one to calculate the 2016 Revenue and the 

second to calculate the difference between Budget and Revenue. 
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DAX Calculated Columns 
Back in the Data Model the Actuals table needs a calculated column to return the year value from 

the Date column. Click Add Column and enter the YEAR function, type-in an equals sign, then a “Y” 

and select the YEAR function from the list by double-clicking or pressing the Tab key. Type-in a “D” to 

trigger the tables and fields list. The final formula reads as follows: 

=YEAR(Data[Date])  

Don't forget your closing bracket for the 

YEAR function, DAX is not as forgiving as 

Excel; it usually closes automatically on 

most functions but not on all. 

 

 

 

 

 

 

 

 

 

Double-click or right-click to rename the field as FinYr. You always drag to move the fields into a 

different order. Now our filter will be really easy to make, it’s so much easier to say “FinYr = 2016” 

than it is to express a range of date values from 1/1/2016 to 31/12/2016. 
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DAX Measures 
Now, back to the Pivot Table to enter a Measure to calculate the 2016 Revenue. DAX does not have 

filtering functions like SUMIFS, SUMIF, COUNTIFS, AVERAGEIFS etc. It has one universal filter 

function that does the job of all of them, namely CALCULATE. 

CALCULATE(Expression, Filter1, Filter2 etc.) 

Expression is the function you want to use, such as SUM, COUNT or AVERAGE etc. and the field you 

want to calculate and then you list the filters to apply. (You may also need other functions like 

FILTER or ALL to help you make more complex filters) 

In Excel, 2016 Revenue would be a job for SUMIF or SUMIFS. In DAX it is: 

=CALCULATE(SUM(Data[Revenue]), Data[FinYr]=2016) 

 

Click Measures, set the Table name to Data, the Measure name to 2016 Revenue and enter the 

formula by typing “C”, “S”, “D”, “D” to trigger the drop down lists. Be careful with your brackets and 

click Check formula before entering. If you have a mouse you can hold down the CTRL key on the 

keyboard and spin the mouse scroll wheel to zoom in or out the view of the formula. 

If your measure is a success then it will appear in 

your Pivot Table. If you have to edit it before it 

works then turn it on in the pivot table field list.  
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Our next measure is entered to calculate the difference between 2016 Revenue and Budget. Don’t 

type-in from scratch, enter opening square brackets, [ to trigger the lists where you can choose the 

measures to include in your calculation. This measure uses the measure previously calculated and 

the existing Sum of Budget (implicit measures), which the Pivot table has calculated. The formula is: 

=[2016 Revenue]-[Sum of Budget] 

 

In the Pivot Table above we have renamed the Sum of Budget field as 2016 Budget.  


